Bug #488

Feature #161: Support the FrSky Sensor Hub Protocol

Hub channels seem to loose their source on resume of app

Added by Hans Cappelle about 6 years ago. Updated almost 6 years ago.

Status:ClosedStart date:06/20/2012
Priority:HighDue date:
Assignee:Android Dashboard Developers% Done:

0%

Category:DebugSpent time:-
Target version:3.0 FrSky hub and sensors

Description

needs investigation. We had this issue before with non hub channels I think.

Associated revisions

Revision 469
Added by Espen Solbu almost 6 years ago

closes #491, refs #488 Channels deriving from another derived channel should now "re-register" itself properly. This should also partially fix #488, but i suspect that issue is deeper, as i often "crash" hub derived channels, while all the other channels still run properly. Deploying as 2.0B8

History

#1 Updated by Hans Cappelle almost 6 years ago

  • Priority changed from Normal to High

#2 Updated by Espen Solbu almost 6 years ago

-- Last Thoughs first as probably most correct ---
hmm looking further, it might be that FrSkyServer.getChannel should use getHubEnabled() instead of _hubEnabled as this value might not have been pulled from settings yet. I am too tired to test though.

-- Previous Ramblings --
Are you thinking of #424? I think the reset() was causing that. (source channel got set to -1 (none))

What is "resume of app"? when re-entering from another app? or when going back to dashboard from another app, or switching models?

I would guess that there can be problems within the registerListenerForChannelUpdates() method or the FrSkyServer.getChannel(). These methods were very quickly modified to support hub channels, it might be that at a given point in time, the FrSkyServer.getChannel cannot access the hub or its channels? not yet instantiated when called?

#3 Updated by Espen Solbu almost 6 years ago

  • Status changed from New to Closed

This issue was indeed caused by channel registration issues. This is solved by r469

However it spawns a new issue. We sometime get into a state where Hub derived channels no longer update.

Also available in: Atom PDF