Bug #414

Feature #161: Support the FrSky Sensor Hub Protocol

prototype Channel support for hubs - seem not to work properly

Added by Espen Solbu over 6 years ago. Updated about 6 years ago.

Status:ClosedStart date:04/27/2012
Priority:NormalDue date:
Assignee:Android Dashboard Developers% Done:

0%

Category:FrSky HubSpent time:-
Target version:3.0 FrSky hub and sensors

Description

The temp channel shows 0 while hub activity show -15
The Altitude channel only shows ints
The rpm channel show 0 regardless

I suspect the source channel are not properly attached. I suspect that a derived channel listening to a hub channel does not listen for the correct channel, check uniqueness of channel id's

History

#1 Updated by Hans Cappelle over 6 years ago

temp and altitude values retested with revision #402 and seems to work fine now. Values were simulator generated. Need to test with actual sensors again.

#2 Updated by Espen Solbu about 6 years ago

  • Parent task set to #161

#3 Updated by Hans Cappelle about 6 years ago

Espen I think this one can be closed also (the prototyping part at least).

#4 Updated by Hans Cappelle about 6 years ago

  • Category set to FrSky Hub
  • Assignee set to Android Dashboard Developers

#5 Updated by Espen Solbu about 6 years ago

  • Status changed from New to Closed

Have you retested it? i have not looked at it for awhile, though it did seem to work when i used a hub channel as source for altitude channel for the screenshots i took for android Market yesterday...

I'll close it for now :)

Also available in: Atom PDF