Task #311

Feature #117: Support multiple model configs with separate channelconfigs

Feature #285: Individual FrSky Alarms for a model

beautify the alarm list

Added by Espen Solbu almost 6 years ago. Updated almost 6 years ago.

Status:ClosedStart date:02/02/2012
Priority:NormalDue date:02/06/2012
Assignee:Espen Solbu% Done:

0%

Category:BeautificationSpent time:-
Target version:2.0 Multiple models

Description

I would like you guys to take a look at the page for the FrSky alarms. I don't like the looks of it, but i feel stuck when it comes to finding something better.

For those that are not set up to build from source, i've attached a screenshot of how it is setup now:
Screenshot

Use the Update feature on this issue, and add notes or comments regarding solution

FrSkyAlarms_proposed.png - Screenshot (52.3 KB) Espen Solbu, 02/03/2012 03:25 pm

History

#2 Updated by Espen Solbu almost 6 years ago

  • Description updated (diff)

#3 Updated by Espen Solbu almost 6 years ago

  • Description updated (diff)

#4 Updated by Espen Solbu almost 6 years ago

  • Description updated (diff)
  • Due date set to 02/06/2012

#5 Updated by Espen Solbu almost 6 years ago

  • Status changed from New to Feedback
  • Priority changed from Low to Normal

#6 Updated by Espen Solbu almost 6 years ago

I have some problems scrolling up and down without modifying alarms as well

#7 Updated by Thorsten Klein almost 6 years ago

Hi Espen,
testing Version 2.0 since you upload the files.
for me the alarm page fits in the moment, so the look is ok. I think it will be getting worse if more Channels and alarms (for sensor hub integration) wikk be added. My advise, leave the look as it is and work with more alarm pages.
Version 2.0 currently runs well. I tested with 3 different models (create a seperate model for alarms) and it works well.
This was tested till today ( In summary 6hrs testing and flying):
- create different models and set different alarms for each. - Status OK
- switch between models and use " Auto send alarms when swapping model" Status OK
- Change Alarm values for each models and send alarms to module - As long as only Bluetooth connectet (Green Status Bar for BT UP and Tx UP)- OK!
As soon as Model connected to battery ( Rx Status Bar green) it causes long delay to change values, scroll down. In 30% of this cases the App crashes complete. Failure is reproducable.

KR
Thorsten

Espen Solbu wrote:

I would like you guys to take a look at the page for the FrSky alarms. I don't like the looks of it, but i feel stuck when it comes to finding something better.

For those that are not set up to build from source, i've attached a screenshot of how it is setup now:
Screenshot

Use the Update feature on this issue, and add notes or comments regarding solution

#8 Updated by Espen Solbu almost 6 years ago

Thorsten Klein wrote:

As soon as Model connected to battery ( Rx Status Bar green) it causes long delay to change values, scroll down. In 30% of this cases the App crashes complete. Failure is reproducable.

Does this seem related to #348? Symptoms, everything in the app "slows down", and it is hard to navigate the app, sometimes also FPS indicator increased much?

If so, this should be fixed now, I will post a new alpha later today.

Regarding alarm pages.
When "phone alarms" are implemented (v4.0) there will be additional pages for this.

#9 Updated by Thorsten Klein almost 6 years ago

Espen Solbu wrote:

If so, this should be fixed now, I will post a new alpha later today.

Regarding alarm pages.
When "phone alarms" are implemented (v4.0) there will be additional pages for this.

TK: 2_0 A02 now installed, will test tomorrow if issue is fixed
Regarding alarm pages : I mentioned to limit the alarm page to max. 4 or 6 alarms and settings . e.g. AD1 Alarm1 / Alarm2, AD2 Alarm1 Alarm2, on one page. Other Alarms and settings, e.g RSSI Alarm1 / Alarm 2 and upcoming alarms ( for hub data´s ) on next pages.

#10 Updated by Espen Solbu almost 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF